Internet Connectivity Issues

September 07, Tue
Affected Service: NSAO Cloud Services NSAO Cloud Desktop NSAO Cloud Email NSAO Cloud Voice Services
  • Identified
    It appears right now large portions of the Internet are un-reachable. This is not apparently specific to any one internet provider. We will update as we have more information.
    Notes see all the issues for 9/07/2021: https://downdetector.com/archive/

    13:10, Sep 07 EDT
  • Monitoring
    We have now confirmed this is an issue with the Spectrum network and they are working on the issue.

    13:44, Sep 07 EDT
  • Monitoring
    Spectrum statement: https://twitter.com/Ask_Spectrum

    14:47, Sep 07 EDT
  • Resolved
    Spectrum customers, we have been advised that Internet services have been restored to the Midwest. We thank you for your patience.

    18:36, Sep 07 EDT
Back to current status