Voice services connectivity issues

December 17, Fri
Affected Service: NSAO Cloud Voice Services
  • Investigating
    Started at: Friday, 17 December 2021 08:57 ET
    Updated at: Friday, 17 December 2021 09:43 ET
    Summary of Issue:
    Some customers may experience connectivity issues while utilizing Voice Services and placing/answering phone calls.
    Business Impact:
    Some users may be unable to place or answer calls. Some Voice Services features may be unavailable.
    Technical Details
    Our System Administrators have identified networking issues and are working with Network engineering to identify and resolve the issue. We'll provide another update as we make progress.

    10:04, Dec 17 EDT
  • Update
    Summary of Issue:
    Some customers may experience connectivity issues while utilising Voice Services and placing/answering phone calls.
    Business Impact:
    Some users may be unable to place or answer calls. Some Voice Services features may be unavailable.
    Technical Details
    Our System Administrators have identified networking issues and are working with Network engineering to identify and resolve the issue. We'll provide another update as we make progress.

    10:55, Dec 17 EDT
  • Update
    Summary of issue:
    We are currently experiencing a network issue that is impacting some of our customers. Our DNS servers in all US data centers are receiving significantly more than normal traffic, which is impacting voice services for some customers. We are actively working to resolve the situation. We sincerely apologize for the inconvenience and will provide more information on the resolution shortly.

    12:42, Dec 17 EDT
  • Resolved
    Summary:
    Voice Services functionality has been restored. All users are able to use Voice Services without issue. Currently, all support channels are operating as normal.

    Business Impact:
    Voice Services are now working as expected.

    Technical Details:
    Our Network Administrators identified the root cause as a DDoS attack that impacted Voice Services functionality across multiple Datacenters. We have now mitigated the issue. All services are now working as expected. Due to a high volume of requested callbacks around this issue, a return call may be delayed or not completed. For any further questions, please call or chat with us.

    12:49, Dec 17 EDT
Back to current status