-
Investigating
Google Drive services are having issues right now for some users.
https://www.google.com/appsstatus#hl=en&v=status
11:28, Sep 15 EST
-
Resolved
From Google:
The problem with Google Drive should be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Google, and we are making continuous improvements to make our systems better.
14:09, Sep 15 EST
Back to current status