History
Subscribe
RSS Feed
Spectrum Internet Issues
August 30, Sun
Affected Service:
NSAO Cloud Services
NSAO Cloud Desktop
NSAO Cloud Email
NSAO Cloud Voice Services
Identified
Spectrum is experiencing issues with their backbone causing parts of the Internet to be unreachable. All NSAO services are working normally.
10:15, Aug 30 EST
Resolved
All Services working normally
15:12, Aug 30 EST
Back to current status