Partial Service Interruption Due to Connectivity

March 23, Wed
Affected Service: NSAO Cloud Desktop
  • Investigating
    We are investigating a connectivity disruption for Spectrum / Charter Internet clients.

    15:17, Mar 22 EDT
  • Testing
    The ISP with the issue Centurylink and Spectrum are starting to report the issue as resolved.
    https://downdetector.com/status/centurylink/

    17:36, Mar 22 EDT
  • Resolved
    No further issues found

    12:11, Mar 23 EDT
Back to current status