A Small Number of Users Cannot Access Exchange

February 27, Thu
Affected Service: NSAO Cloud Email
  • Fixing
    Started at: 02/27/2020 01:40 AM ET

    Updated at: 02/27/2020 03:08 AM ET

    Summary of Issue: A few mailboxes might be temporarily not accessible via Outlook, OWA and mobile clients.

    Business Impact: Users might receive an error "Site cannot be reached" when trying to connect to their mailboxes through OWA/webmail, and may be unable to connect via Outlook.

    Technical Details Our System Administrators, Security and Network Engineering teams are working towards restoring mailbox access for all users. We will provide further updates as we make progress.

    07:25, Feb 27 EDT
  • Resolved
    Our System Administrators, Security and Network Engineering teams installed required updates on the servers to restore mailbox access for all users on EXCH032 domain. All users are able to access their mailboxes normally at this time. If you continue to experience any issues, please contact our Support Team at (330) 966-8097

    09:13, Feb 27 EDT
Back to current status